summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorIvan Gankevich <igankevich@capybaramail.xyz>2023-04-15 21:01:08 +0200
committerLudovic Courtès <ludo@gnu.org>2023-05-25 12:51:16 +0200
commita9cde26133bd98498869a3528d9dff0d3f456a96 (patch)
tree18a26593c34ecb7f0dae46b96f52f855b356162b /gnu
parent0d320a10bf09615c10af2c8bf3df1bdcbea8eb6e (diff)
downloadguix-a9cde26133bd98498869a3528d9dff0d3f456a96.tar.gz
gnu: Add mouseloupe.
* gnu/packages/accessibility.scm (mouseloupe): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/accessibility.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/accessibility.scm b/gnu/packages/accessibility.scm
index 3613bd8c45..0b06a189ea 100644
--- a/gnu/packages/accessibility.scm
+++ b/gnu/packages/accessibility.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2019 Andrew Miloradovsky <andrew@interpretmath.pw>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
+;;; Copyright © 2023 Ivan Gankevich <igankevich@capybaramail.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -350,3 +351,38 @@ CONFIG_SPEAKUP=m
 CONFIG_SPEAKUP_SOFT=m
 @end itemize")
     (home-page "https://github.com/linux-speakup/espeakup")))
+
+(define-public mouseloupe
+  (package
+    (name "mouseloupe")
+    (version "0.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://sourceforge/" name "/" name "/v" version
+                            "/" name "-v" version ".tar.gz"))
+        (sha256 (base32 "0cvdkfakw7cix07j0c4iy10fkbqn6n8l1gr5dd3iy4f2d9bkza43"))))
+    (build-system gnu-build-system)
+    (arguments
+      `(#:tests? #f ; there are no tests
+        #:phases
+        (modify-phases %standard-phases
+          (delete 'configure)
+          (add-before 'build 'strtof
+            (lambda _
+              (substitute* "mouseloupe.c"
+                (("\\bstrtof\\b") "mouseloupe_strtof"))))
+          (replace 'install
+            (lambda _
+              (define out (assoc-ref %outputs "out"))
+              (install-file "mouseloupe" (string-append out "/bin"))
+              (install-file "mouseloupe.1.gz" (string-append out "/share/man/man1")))))))
+    (native-inputs
+      (list pkg-config))
+    (inputs
+      (list libx11 libxext libxcomposite libxdamage libxrender))
+    (synopsis "Screen magnifier tool for people with low vision")
+    (description "MouseLoupe is a kind of magnifying glass combined with the mouse pointer
+which allows an easy and pleasant web navigation.")
+    (home-page "https://sourceforge.net/projects/mouseloupe/")
+    (license license:gpl2+)))