summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2022-09-01 20:33:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-09-01 20:36:42 +0200
commitaa5e0307137dd68279fc8b02ac623386208458cd (patch)
tree302b7b570f95d6801ad4f4b27b4a3c0aa7c1f703 /gnu
parent839349e187170c396899c134762389e88026b84f (diff)
downloadguix-aa5e0307137dd68279fc8b02ac623386208458cd.tar.gz
gnu: Add convert-samples.
* gnu/packages/radio.scm (convert-samples): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/radio.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 41bd3e38a9..132cc95f12 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1973,6 +1973,49 @@ defined radio with support for rtl-sdr.")
 program that can be used to build simple signal processing flow graphs.")
     (license license:gpl3+)))
 
+(define-public convert-samples
+  (package
+    (name "convert-samples")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/glv2/convert-samples")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d9w9m5agi8fiv1wk8nhjrbm2jkm2fks4ymbxkn0xphbwj3gwr7i"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list autoconf automake))
+    (inputs
+     (list liquid-dsp))
+    (synopsis "SDR samples converter")
+    (description
+     "@code{convert-samples} is a command-line program to convert samples
+received from software defined radios from one format to another.
+
+Supported formats:
+@itemize
+@item s8: signed 8 bit integer
+@item u8: unsigned 8 bit integer
+@item s16: signed 16 bit integer
+@item u16: unsigned 16 bit integer
+@item s32: signed 32 bit integer
+@item u32: unsigned 32 bit integer
+@item f32: 32 bit float
+@item cs8: complex made of signed 8 bit integers
+@item cu8: complex made of unsigned 8 bit integers
+@item cs16: complex made of signed 16 bit integers
+@item cu16: complex made of unsigned 16 bit integers
+@item cs32: complex made of signed 32 bit integers
+@item cu32: complex made of unsigned 32 bit integers
+@item cf32: complex made of 32 bit floats
+@end itemize")
+    (home-page "https://github.com/glv2/convert-samples")
+    (license license:gpl3+)))
+
 (define-public serialdv
   (package
     (name "serialdv")