summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-10 09:17:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-11 14:39:38 +0200
commitaa88221652c6043fec4a2906fcfaaf50e430f763 (patch)
tree0750fff14caf344839803e7b4a291818b4dfaf25 /gnu
parent4ee55f4c83d616ad719c691af75b1b744f832ef9 (diff)
downloadguix-aa88221652c6043fec4a2906fcfaaf50e430f763.tar.gz
gnu: Add texlive-frenchmath.
* gnu/packages/tex.scm (texlive-frenchmath): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc673ba3ce..b4f0fa2622 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4165,6 +4165,37 @@ level, as appropriate.  The package provides an alternative to the use of the
 @code{\\sideset} command in the @code{amsmath} package.")
     (license license:lppl)))
 
+(define-public texlive-frenchmath
+  (package
+    (name "texlive-frenchmath")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/frenchmath/"
+                   "source/latex/frenchmath/"
+                   "tex/latex/frenchmath/")
+             (base32
+              "0f6x5glpvjxvl5l8nvrjcbc6mfqpyv77y4qyxaaqxcwyhbkp5fw7")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/frenchmath")
+    (synopsis "Typesetting mathematics according to French rules")
+    (description
+     "The package provides:
+
+@itemize
+@item capital letters in roman (upright shape) in mathematical mode according
+to French rule (can be optionally disabled),
+@item optionally lowercase Greek letters in upright shape,
+@item correct spacing in math mode after commas, before a semicolon and around
+square brackets,
+@item some useful macros and aliases for symbols used in France such as
+@code{\\infeg}, @code{\\supeg}, @code{\\paral}, @item several macros for
+writing french operator names like @emph{pgcd}, @emph{ppcm}, @emph{Card},
+@emph{rg}, @emph{Vect}.
+@end itemize")
+    (license license:lppl1.3+)))
+
 (define-public texlive-functan
   (package
     (name "texlive-functan")