summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-12 21:12:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-13 08:55:47 +0300
commitab53bdf01ce4ab36c2522eaa69f917ad2481e127 (patch)
treeec5a5eece6f31307898d0d8d730c5fc0cfd04d4d /gnu
parent2b8d4ce819529fe9b094a4aba058e607abc3a364 (diff)
downloadguix-ab53bdf01ce4ab36c2522eaa69f917ad2481e127.tar.gz
gnu: isl: Update to 0.18.
* gnu/packages/gcc.scm (isl): Update to 0.18.
(isl-0.11): New variable.
(gcc@4.8, cloog)[inputs]: Use isl-0.11.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 4b495ccbae..7375457a99 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -354,7 +354,7 @@ Go.  It also includes runtime support libraries for these languages.")
               (patches (search-patches "gcc-arm-link-spec-fix.patch"))))
     (supported-systems %supported-systems)
     (inputs
-     `(("isl" ,isl)
+     `(("isl" ,isl-0.11)
        ("cloog" ,cloog)
        ,@(package-inputs gcc-4.7)))))
 
@@ -670,7 +670,7 @@ as the 'native-search-paths' field."
 (define-public isl
   (package
     (name "isl")
-    (version "0.11.1")
+    (version "0.18")
     (source (origin
              (method url-fetch)
              (uri (list (string-append
@@ -681,8 +681,7 @@ as the 'native-search-paths' field."
                                        name "-" version ".tar.gz")))
              (sha256
               (base32
-               "13d9cqa5rzhbjq0xf0b2dyxag7pqa72xj9dhsa03m8ccr1a4npq9"))
-             (patches (search-patches "isl-0.11.1-aarch64-support.patch"))))
+               "06ybml6llhi4i56q90jnimbcgk1lpcdwhy9nxdxra2hxz3bhz2vb"))))
     (build-system gnu-build-system)
     (inputs `(("gmp" ,gmp)))
     (home-page "http://isl.gforge.inria.fr/")
@@ -700,6 +699,24 @@ reduction, transitive closures on maps (which may encode infinite graphs),
 dependence analysis and bounds on piecewise step-polynomials.")
     (license lgpl2.1+)))
 
+(define-public isl-0.11
+  (package
+    (inherit isl)
+    (name "isl")
+    (version "0.11.1")
+    (source (origin
+             (method url-fetch)
+             (uri (list (string-append
+                         "http://isl.gforge.inria.fr/isl-"
+                         version
+                         ".tar.bz2")
+                        (string-append %gcc-infrastructure
+                                       name "-" version ".tar.gz")))
+             (sha256
+              (base32
+               "13d9cqa5rzhbjq0xf0b2dyxag7pqa72xj9dhsa03m8ccr1a4npq9"))
+             (patches (search-patches "isl-0.11.1-aarch64-support.patch"))))))
+
 (define-public cloog
   (package
     (name "cloog")
@@ -719,7 +736,7 @@ dependence analysis and bounds on piecewise step-polynomials.")
       (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (inputs `(("gmp" ,gmp)
-              ("isl" ,isl)))
+              ("isl" ,isl-0.11)))
     (arguments '(#:configure-flags '("--with-isl=system")))
     (home-page "http://www.cloog.org/")
     (synopsis "Library to generate code for scanning Z-polyhedra")