summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-02 00:38:13 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 22:14:43 +0100
commitac2fe449e7d20bf0b5be3623e29de2d355eb0577 (patch)
tree9e1a84d3cc99a3b579fbdf1678a659dde79f207f /gnu
parent0c15230db1a39897cbdc6dc7c47417fa3ece85e7 (diff)
downloadguix-ac2fe449e7d20bf0b5be3623e29de2d355eb0577.tar.gz
gnu: Add mupen64plus-audio-sdl.
* gnu/packages/games.scm (mupen64plus-audio-sdl): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 89e9ca59dd..891abf4f71 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -1261,6 +1261,52 @@ which is capable of accurately playing many games.  This package contains the
 core library.")
     (license license:gpl2+)))
 
+(define-public mupen64plus-audio-sdl
+  (package
+    (name "mupen64plus-audio-sdl")
+    (version "2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/mupen64plus/mupen64plus-audio-sdl/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0ss6w92n2rpfnazhg9lbq0nvs3fqx93nliz3k3wjxdlx4dpi7h3a"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("which" ,which)))
+    (inputs
+     `(("mupen64plus-core" ,mupen64plus-core)
+       ("sdl2" ,sdl2)))
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         ;; The mupen64plus build system has no configure phase.
+         (delete 'configure)
+         ;; Makefile is in a subdirectory.
+         (add-before
+          'build 'cd-to-project-dir
+          (lambda _
+            (chdir "projects/unix"))))
+       #:make-flags
+       (let ((out (assoc-ref %outputs "out"))
+             (m64p (assoc-ref %build-inputs "mupen64plus-core")))
+         (list "all"
+               (string-append "PREFIX=" out)
+               (string-append "APIDIR=" m64p "/include/mupen64plus")))
+       ;; There are no tests.
+       #:tests? #f))
+    (home-page "http://www.mupen64plus.org/")
+    (synopsis "Mupen64Plus SDL input plugin")
+    (description
+     "Mupen64Plus is a cross-platform plugin-based Nintendo 64 (N64) emulator
+which is capable of accurately playing many games.  This package contains the
+SDL audio plugin.")
+    (license license:gpl2+)))
+
 (define-public nestopia-ue
   (package
     (name "nestopia-ue")