summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 17:53:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:08 +0200
commitacb958938a7d850b2cd8cc373bcaa30b6d2f2c43 (patch)
tree406bb6c19915c256b5dc348bf53a38181e8b5f3a /gnu
parent7b9e90e40deceb74920adfdaaa758938f13fe594 (diff)
downloadguix-acb958938a7d850b2cd8cc373bcaa30b6d2f2c43.tar.gz
gnu: Add python-typeshed-client.
* gnu/packages/python-xyz.scm (python-typeshed-client): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b5456a4472..0753c42ff3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31014,6 +31014,24 @@ Python, with static types.")
     (description "This package provides typing stubs for urllib3.")
     (license license:asl2.0)))
 
+(define-public python-typeshed-client
+  (package
+    (name "python-typeshed-client")
+    (version "2.3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "typeshed_client" version))
+              (sha256
+               (base32
+                "1vdwp1jjg27b22qxgm49v21nb8vm1iki3bfsm0fnq2rsz5alfwz2"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-importlib-resources))
+    (home-page "https://github.com/JelleZijlstra/typeshed_client")
+    (synopsis "Library for accessing stubs in typeshed")
+    (description
+     "This package provides a library for accessing stubs in typeshed.")
+    (license license:expat)))
+
 (define-public python-psycopg2-binary
   (package
     (name "python-psycopg2-binary")