summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAdriano Peluso <catonano@gmail.com>2017-03-28 12:25:06 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-05-27 18:12:34 +0530
commitad2ef260738982aa3493f1c54aa06aad8a827eea (patch)
tree0ba7aedc4073d527720ffa01b45c4b29b3f5d69d /gnu
parent3dba9b378223d1addac90e5846a9f191f38806af (diff)
downloadguix-ad2ef260738982aa3493f1c54aa06aad8a827eea.tar.gz
gnu: Add python-sql.
* gnu/packages/python.scm (python-sql, python2-sql): New variables.

Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b958199bdb..174ebfcb03 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -14804,3 +14804,24 @@ information.")
 
 (define-public python2-packaging
   (package-with-python2 python-packaging))
+
+(define-public python-sql
+  (package
+    (name "python-sql")
+    (version "0.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "python-sql" version))
+       (sha256
+        (base32
+         "0p6kaqj02vz0habmdx37zjk6hjxdfm8aw737zs059vvpr70ird87"))))
+    (build-system python-build-system)
+    (home-page "https://python-sql.tryton.org/")
+    (synopsis "Library to write SQL queries in a pythonic way")
+    (description "@code{python-sql} is a library to write SQL queries, that
+transforms idiomatic python function calls to well-formed SQL queries.")
+    (license license:bsd-3)))
+
+(define-public python2-sql
+  (package-with-python2 python-sql))