summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 14:03:05 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-29 17:28:38 +0100
commitad7749a1273ccd2556acd4d24388956d6962a723 (patch)
tree9ffd3c2efb0ddf6b1ba5189552ff8e8498a0ae31 /gnu
parent7a584b0e5613909a57f00f00e4bcfdf6e563cb51 (diff)
downloadguix-ad7749a1273ccd2556acd4d24388956d6962a723.tar.gz
gnu: igt-gpu-tools: Update to 1.25.
* gnu/packages/admin.scm (igt-gpu-tools): Update to 1.25.
[build-system]: Switch to Meson.
[native-inputs]: Remove autoconf, automake, and libtool.
Add bison & flex.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/admin.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 20d5978e6d..a5bff31db5 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -3108,7 +3108,7 @@ buffers.")
 (define-public igt-gpu-tools
   (package
     (name "igt-gpu-tools")
-    (version "1.24")
+    (version "1.25")
     (source
      (origin
        (method git-fetch)
@@ -3117,8 +3117,8 @@ buffers.")
              (commit (string-append "igt-gpu-tools-" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1gpdjs5aj6vsnzwcjvw5bb120lgffvvshi4202phr0bzw3b92ky8"))))
-    (build-system gnu-build-system)
+        (base32 "1lvhkdhilw0fn4nzkpfwvrhiv8d92h811qs2v6ac3p5w7v86a9zm"))))
+    (build-system meson-build-system)
     (arguments
      `(#:tests? #f))            ; many of the tests try to load kernel modules
     (inputs
@@ -3135,9 +3135,8 @@ buffers.")
        ("procps" ,procps)
        ("util-macros" ,util-macros)))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
+     `(("bison" ,bison)
+       ("flex" ,flex)
        ("pkg-config" ,pkg-config)))
     (home-page "https://gitlab.freedesktop.org/drm/igt-gpu-tools")
     (synopsis "Tools for development and testing of the Intel DRM driver")