summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-09-26 18:03:40 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-09-28 00:19:11 +0200
commitae05b1856ff0f865af7353bf8b575fdb79888770 (patch)
treef49f2d690740ef0bb63ca7e537b2b79e810a943f /gnu
parentaab56ab7da0d8bd70ced157619d2a56fd6c8727c (diff)
downloadguix-ae05b1856ff0f865af7353bf8b575fdb79888770.tar.gz
gnu: Add arandr.
* gnu/packages/xdisorg.scm (arandr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 7aa82fe312..96e7c3ae71 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -30,12 +30,15 @@
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages xml)
@@ -44,6 +47,34 @@
 
 ;; packages outside the x.org system proper
 
+(define-public arandr
+  (package
+    (name "arandr")
+    (version "0.1.8")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://christian.amsuess.com/tools/" name
+                                  "/files/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0d574mbmhaqmh7kivaryj2hpghz6xkvic9ah43s1hf385y7c33kd"))))
+    (build-system python-build-system)
+    (arguments `(#:python ,python-2     ;incompatible with python 3
+                 #:tests? #f))          ;no tests
+    (inputs `(("pygtk" ,python2-pygtk)))
+    (native-inputs `(("gettext"           ,gnu-gettext)
+                     ("python-docutils"   ,python2-docutils)
+                     ("python-setuptools" ,python2-setuptools)))
+    (home-page "https://christian.amsuess.com/tools/arandr/")
+    (synopsis "Another RandR graphical user interface")
+    ;; TRANSLATORS: "X11 resize-and-rotate" should not be translated.
+    (description "ARandR is designed to provide a simple visual front end for
+the X11 resize-and-rotate (RandR) extension.  Relative monitor positions are
+shown graphically and can be changed in a drag-and-drop way.  Configurations
+are saved as executable shell scripts which can be loaded without using this
+program.")
+    (license license:gpl3+)))
+
 (define-public xclip
   (package
     (name "xclip")