summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2019-10-03 15:46:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 21:38:08 +0100
commitae105119812bca8e9f2d74dcf11be95a293c0cc6 (patch)
tree03418fb47c2cd98b8ea525a0ccd836bf56da397a /gnu
parent2e59a63b41b5c0a7ee70e45b2e6538cfded2e758 (diff)
downloadguix-ae105119812bca8e9f2d74dcf11be95a293c0cc6.tar.gz
gnu: Add r-httpcode.
* gnu/packages/cran.scm (r-httpcode): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e022651616..1e55606ef9 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20844,3 +20844,22 @@ as possible (with tests to prove it).")
 carrying out convergence diagnostics and statistical and graphical analysis of
 @dfn{Markov chain Monte Carlo} (MCMC) sampling output.")
     (license license:gpl2+)))
+
+(define-public r-httpcode
+  (package
+    (name "r-httpcode")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "httpcode" version))
+              (sha256
+               (base32
+                "06k853ihwzkcx4z3jzazpb03p91frqkwz18jy4fwr8j2nwyqbhgv"))))
+    (build-system r-build-system)
+    (home-page "https://github.com/sckott/httpcode")
+    (synopsis "HTTP status code helper")
+    (description "@code{httpcode} provides functionality for finding and
+explaining the meaning of @code{HTTP} status codes.  Functions are included for
+searching for codes by full or partial number, by message, and to get
+appropriate dog and cat images for many status codes.")
+    (license license:expat)))