summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:31 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:21 +0300
commitb08be61a026fae900d37c158fd1b251bf21f5450 (patch)
tree651724d6fe7842bdbef474774085900cb5f313af /gnu
parentf9b8f38908da660a2f775de2656e47f3e9ec75bc (diff)
downloadguix-b08be61a026fae900d37c158fd1b251bf21f5450.tar.gz
gnu: Add python-pysynphot.
* gnp/packages/astronomy.scm (python-pysynphot): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/astronomy.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1371b24667..25b6d6a07e 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2687,6 +2687,38 @@ astrophysical simulations supporting PKDGRAV/Gasoline, Gadget, Gadget4/Arepo,
 N-Chilada and RAMSES AMR outputs.")
     (license license:gpl3+)))
 
+(define-public python-pysynphot
+  (package
+    (name "python-pysynphot")
+    (version "2.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pysynphot" version))
+              (sha256
+               (base32
+                "1rr29m63bnj47f6gvbvg3pm1296x14ad29c6qd0sdj4f4ilrzhj5"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-before 'check 'set-env-data-path
+                          (lambda _
+                            (setenv "PYSYN_CDBS"
+                                    (string-append #$output "/crds")))))))
+    (native-inputs (list python-pytest python-pytest-remotedata
+                         python-setuptools-scm))
+    (propagated-inputs (list python-astropy python-beautifulsoup4 python-numpy
+                             python-pytest-astropy-header python-six))
+    (home-page "https://github.com/spacetelescope/pysynphot")
+    (synopsis "Python Synthetic Photometry Utilities")
+    (description
+     "Astrolib PySynphot (hereafter referred to only as pysynphot) is an
+object-oriented replacement for STSDAS SYNPHOT synthetic photometry package in
+IRAF.  @code{pysynphot} simulates photometric data and spectra as they are
+observed with the Hubble Space Telescope (HST).  Passbands for standard
+photometric systems are available, and users can incorporate their own filters,
+spectra, and data.")
+    (license license:bsd-3)))
+
 (define-public python-sep
   (package
     (inherit libsep)