summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 13:59:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 14:46:25 +0200
commitb0926a2fd1069011c223ef314d2df71a756534d0 (patch)
tree1001789f6090b800ea299592711eb63d562be08f /gnu
parent1437e6ff687ca187e76c342d2cfaa1bf2e40ba0d (diff)
downloadguix-b0926a2fd1069011c223ef314d2df71a756534d0.tar.gz
gnu: Add texlive-collection-formatsextra.
* gnu/packages/tex.scm (texlive-collection-formatsextra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index efe428d7c1..b295a70739 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -37063,6 +37063,45 @@ manipulation, mft, fontinst, etc.  Manipulating OpenType, TrueType, Type 1,and
 for manipulation of PostScript and other image formats.")
     (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
 
+(define-public texlive-collection-formatsextra
+  (package
+    (name "texlive-collection-formatsextra")
+    (version (number->string %texlive-revision))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments (list #:builder #~(mkdir #$output)))
+    (propagated-inputs
+     (list texlive-aleph
+           texlive-antomega
+           texlive-collection-basic
+           texlive-collection-latex
+           texlive-edmac
+           texlive-eplain
+           texlive-hitex
+           texlive-jadetex
+           texlive-lambda
+           texlive-lollipop
+           texlive-mltex
+           texlive-mxedruli
+           texlive-omega
+           texlive-omegaware
+           texlive-otibet
+           texlive-passivetex
+           texlive-psizzl
+           texlive-startex
+           texlive-texsis
+           texlive-xmltex
+           texlive-xmltexconfig))
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Additional TeX formats")
+    (description
+     "This is a collection of TeX formats, i.e., large-scale macro packages
+designed to be dumped into @file{.fmt} files --- excluding the most common
+ones, such as LaTeX and ConTeXt, which have their own package(s).  It also
+includes the Aleph engine and related Omega formats and packages, and the
+HiTeX engine and related.")
+    (license (license:fsf-free "https://www.tug.org/texlive/copying.html"))))
+
 (define-public texlive-collection-langczechslovak
   (package
     (name "texlive-collection-langczechslovak")