summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-08-07 22:03:03 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-10-20 17:45:30 +0800
commitb099e5e980339d0ebe9e09f868e13a23b6305762 (patch)
tree620b0ea867309b168c138ab63533b155f49e1296 /gnu
parente5f34b6777689c5a89328af1358acd36eac61a3e (diff)
downloadguix-b099e5e980339d0ebe9e09f868e13a23b6305762.tar.gz
gnu: exiv2: Get rid of reference to GCC.
This fixes <https://issues.guix.gnu.org/57677>.

* gnu/packages/image.scm (exiv2)[arguments]: Add phase to
remove _GLIBCXX_ASSERTIONS from compiler flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index dadb5f3796..d237bf689c 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1528,6 +1528,12 @@ channels.")
                                "-DEXIV2_ENABLE_BMFF=ON")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-gcc-reference
+           (lambda _
+             ;; _GLIBCXX_ASSERTIONS brings reference to GCC.
+             (substitute* "cmake/compilerFlags.cmake"
+               (("add_compile_options[(]-Wp,-D_GLIBCXX_ASSERTIONS[)]")
+                ""))))
          (add-after 'install 'delete-static-libraries
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))