summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-03-24 11:05:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-03-24 11:06:01 +0100
commitb0d1da986b262685d092bb192feb49ab9db1dd8a (patch)
tree810022a79575f51f02ac9466fd8c12fb92df05d3 /gnu
parent8ff63864916f40b5eb03a96192cb59a2e97cafe5 (diff)
downloadguix-b0d1da986b262685d092bb192feb49ab9db1dd8a.tar.gz
gnu: r-harmony: Update to 0.1.
* gnu/packages/cran.scm (r-harmony): Update to 0.1.
[native-inputs]: Add autoconf.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm73
1 files changed, 39 insertions, 34 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 39caf56a13..fe29b9f581 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -42,6 +42,7 @@
   #:use-module (guix utils)
   #:use-module (guix build-system r)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages bioinformatics)
   #:use-module (gnu packages c)
@@ -15690,43 +15691,47 @@ dataset-specific factors.")
     (license license:gpl3)))
 
 (define-public r-harmony
-  ;; There are no tagged commits
-  (let ((commit "4d1653870d4dd70fff1807c182882db1fbf9af5a")
-        (revision "1"))
-    (package
-      (name "r-harmony")
-      (version (git-version "1.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/immunogenomics/harmony")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "1gasdldr4aalr9h2q9kmm3y4i7azkgnhdn4bmvsszs7lg9xacw85"))))
-      (build-system r-build-system)
-      (propagated-inputs
-       `(("r-cowplot" ,r-cowplot)
-         ("r-dplyr" ,r-dplyr)
-         ("r-ggplot2" ,r-ggplot2)
-         ("r-irlba" ,r-irlba)
-         ("r-matrix" ,r-matrix)
-         ("r-rcpp" ,r-rcpp)
-         ("r-rcpparmadillo" ,r-rcpparmadillo)
-         ("r-rcppprogress" ,r-rcppprogress)
-         ("r-rlang" ,r-rlang)
-         ("r-tibble" ,r-tibble)
-         ("r-tidyr" ,r-tidyr)))
-      (home-page "https://github.com/immunogenomics/harmony")
-      (synopsis "Integration of single cell sequencing data")
-      (description
-       "This package provides an implementation of the Harmony algorithm for
+  (package
+    (name "r-harmony")
+    (version "0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/immunogenomics/harmony")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "05r401q09rbr6fqhb9mbd95082cjdi3nag1cv6zn96xkr0f6imq9"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (for-each delete-file '("config.status" "configure"))
+           #t))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-cowplot" ,r-cowplot)
+       ("r-dplyr" ,r-dplyr)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-irlba" ,r-irlba)
+       ("r-matrix" ,r-matrix)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-rcppprogress" ,r-rcppprogress)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyr" ,r-tidyr)))
+    (native-inputs
+     `(("autoconf" ,autoconf)))
+    (home-page "https://github.com/immunogenomics/harmony")
+    (synopsis "Integration of single cell sequencing data")
+    (description
+     "This package provides an implementation of the Harmony algorithm for
 single cell integration, described in Korsunsky et al
 @url{doi.org/10.1101/461954}.  The package includes a standalone Harmony
 function and interfaces to external frameworks.")
-      (license license:gpl3))))
+    (license license:gpl3)))
 
 (define-public r-covr
   (package