summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-15 19:09:02 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-15 23:30:26 +0100
commitb1a19ab6e28277f0f9c72961be3cf709bd14e6e2 (patch)
treefad6149b6429734c671e649e43e961049e1c3014 /gnu
parenteab9807fb38b70e203ac965f2705c76adaedcc07 (diff)
downloadguix-b1a19ab6e28277f0f9c72961be3cf709bd14e6e2.tar.gz
gnu: r-biostrings: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-biostrings): Move from here...
* gnu/packages/bioconductor.scm (r-biostrings): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm27
-rw-r--r--gnu/packages/bioinformatics.scm27
2 files changed, 27 insertions, 27 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6482d8e4c1..2b7d65023d 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1686,6 +1686,33 @@ functions for parallel evaluation, tailored to use with Bioconductor
 objects.")
     (license (list license:gpl2+ license:gpl3+))))
 
+(define-public r-biostrings
+  (package
+    (name "r-biostrings")
+    (version "2.58.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "Biostrings" version))
+              (sha256
+               (base32
+                "1rbqhs73mhfr1gi0rx28jiyan7i3hb45ai3jpl1656fnrhgjfxq5"))))
+    (properties
+     `((upstream-name . "Biostrings")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-crayon" ,r-crayon)
+       ("r-iranges" ,r-iranges)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-xvector" ,r-xvector)))
+    (home-page "https://bioconductor.org/packages/Biostrings")
+    (synopsis "String objects and algorithms for biological sequences")
+    (description
+     "This package provides memory efficient string containers, string
+matching algorithms, and other utilities, for fast manipulation of large
+biological sequences or sets of sequences.")
+    (license license:artistic2.0)))
+
 (define-public r-category
   (package
     (name "r-category")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index af3fa36b19..415210085e 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7691,33 +7691,6 @@ including VCF header and contents in RDF and JSON.")
     (home-page "https://github.com/vcflib/bio-vcf")
     (license license:expat)))
 
-(define-public r-biostrings
-  (package
-    (name "r-biostrings")
-    (version "2.58.0")
-    (source (origin
-              (method url-fetch)
-              (uri (bioconductor-uri "Biostrings" version))
-              (sha256
-               (base32
-                "1rbqhs73mhfr1gi0rx28jiyan7i3hb45ai3jpl1656fnrhgjfxq5"))))
-    (properties
-     `((upstream-name . "Biostrings")))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-biocgenerics" ,r-biocgenerics)
-       ("r-crayon" ,r-crayon)
-       ("r-iranges" ,r-iranges)
-       ("r-s4vectors" ,r-s4vectors)
-       ("r-xvector" ,r-xvector)))
-    (home-page "https://bioconductor.org/packages/Biostrings")
-    (synopsis "String objects and algorithms for biological sequences")
-    (description
-     "This package provides memory efficient string containers, string
-matching algorithms, and other utilities, for fast manipulation of large
-biological sequences or sets of sequences.")
-    (license license:artistic2.0)))
-
 (define-public r-rsamtools
   (package
     (name "r-rsamtools")