summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGuillaume LE VAILLANT <glv@posteo.net>2019-08-08 15:54:46 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2019-09-18 11:55:42 +0200
commitb1df0d9f7734c883e76a59c8afc4796c6fe8771b (patch)
treec47f3f2c04c16e68cd637236c0370396d9e74664 /gnu
parent66226d5d41868c7d60c8725efaeb3dba0a0a58f7 (diff)
downloadguix-b1df0d9f7734c883e76a59c8afc4796c6fe8771b.tar.gz
gnu: Add cl-ledger.
* gnu/packages/lisp.scm (sbcl-cl-ledger, cl-ledger, ecl-cl-ledger): New
  variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8cd27c8d54..6a5e8da664 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -7204,3 +7204,48 @@ purpose of financial calculations."))))
 
 (define-public ecl-cambl
   (sbcl-package->ecl-package sbcl-cambl))
+
+(define-public sbcl-cl-ledger
+  (let ((commit "08e0be41795e804cd36142e51756ad0b1caa377b")
+        (revision "1"))
+    (package
+      (name "sbcl-cl-ledger")
+      (version (git-version "4.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ledger/cl-ledger.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1via0qf6wjcyxnfbmfxjvms0ik9j8rqbifgpmnhrzvkhrq9pv8h1"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("cambl" ,sbcl-cambl)
+         ("cl-ppcre" ,sbcl-cl-ppcre)
+         ("local-time" ,sbcl-local-time)
+         ("periods-series" ,sbcl-periods-series)))
+      (arguments
+       '(#:phases
+         (modify-phases %standard-phases
+           (add-after 'unpack 'fix-system-definition
+             (lambda _
+               (substitute* "cl-ledger.asd"
+                 (("  :build-operation program-op") "")
+                 (("  :build-pathname \"cl-ledger\"") "")
+                 (("  :entry-point \"ledger::main\"") ""))
+               #t)))))
+      (synopsis "Common Lisp port of the Ledger accounting system")
+      (description
+       "CL-Ledger is a Common Lisp port of the Ledger double-entry accounting
+system.")
+      (home-page "https://github.com/ledger/cl-ledger")
+      (license license:bsd-3))))
+
+(define-public cl-ledger
+  (sbcl-package->cl-source-package sbcl-cl-ledger))
+
+(define-public ecl-cl-ledger
+  (sbcl-package->ecl-package sbcl-cl-ledger))