summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-10 01:06:40 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-10 01:17:21 +0200
commitb2193c359a3a6c6bc6db68b22b3dc29b8421dc1a (patch)
treee4b03bb0f2933446284e2602ef2e372c536ffd7e /gnu
parent83f0d3a5c8a1f551d7a92283d445fb605f9fb069 (diff)
downloadguix-b2193c359a3a6c6bc6db68b22b3dc29b8421dc1a.tar.gz
gnu: xclip: Update to 0.13.
Yet another GitHub casualty. See: https://sourceforge.net/projects/xclip/

* gnu/packages/xdisorg.scm (xclip): Update to 0.13.
[source, home-page]: Change to new home.
[native-inputs]: Add AUTOCONF and AUTOMAKE.
[arguments]: Add "bootstrap" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 91abf66945..97f68e872a 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -14,7 +14,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
-;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2016 Petter <petter@mykolab.ch>
 ;;; Copyright © 2017 Mekeor Melire <mekeor.melire@gmail.com>
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
@@ -47,6 +47,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
@@ -117,22 +118,29 @@ program.")
 (define-public xclip
   (package
     (name "xclip")
-    (version "0.12")
+    (version "0.13")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append
-              "mirror://sourceforge/" name "/" name "/" version "/"
-              name "-" version ".tar.gz"))
+        (uri (string-append "https://github.com/astrand/xclip"
+                            "/archive/" version ".tar.gz"))
         (sha256
           (base32
-           "0ibcf46rldnv0r424qcnai1fa5iq3lm5q5rdd7snsi5sb78gmixp"))))
+           "0n7pczk9vv30zf8qfln8ba3hnif9yfdxg0m84djac469wc28hnya"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f))   ; There is no test suite
+     '(#:tests? #f     ; There is no test suite
+       #:phases
+       (modify-phases %standard-phases
+         ;; Since version 0.13, bootstrapped releases are no longer available.
+         (add-after 'unpack 'bootstrap
+           (lambda _ (zero? (system* "autoreconf" "-v")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)))
     (inputs `(("libxmu" ,libxmu)
               ("libxt" ,libxt)))
-    (home-page "http://xclip.sourceforge.net/")
+    (home-page "https://github.com/astrand/xclip")
     (synopsis "Command line interface to X11 clipboard")
     (description "Xclip is a command line interface to the X11 clipboard.  It
 can also be used for copying files, as an alternative to sftp/scp, thus