summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-12-11 01:48:03 -0500
committerLeo Famulari <leo@famulari.name>2016-12-11 02:04:38 -0500
commitb245f7589ee65a29eddaf934dc2bff333a9b2e73 (patch)
tree7bee3daeb64df2681ea1f09c4b9d18ba8fea0e80 /gnu
parent0e8b7b1c351a2307bfc33211b4d76dbe7dfa01ef (diff)
downloadguix-b245f7589ee65a29eddaf934dc2bff333a9b2e73.tar.gz
gnu: diffoscope: Update to 63.
* gnu/packages/package-management.scm (diffoscope): Update to 63.
[arguments]: Remove obsolete 'disable-failing-test' and 'disable-egg-zipping'
phases. The former was fixed upstream, and the latter is fixed by the new Python
build system.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm21
1 files changed, 3 insertions, 18 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 099cbb64d8..7083a1664c 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -482,13 +482,13 @@ transactions from C or Python.")
 (define-public diffoscope
   (package
     (name "diffoscope")
-    (version "62")
+    (version "63")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri name version))
               (sha256
                (base32
-                "127b4gsw11hjbha5jpz5i42pc142h52pwzs1p792047y0j1yjg8z"))))
+                "12q5d2nszql1g4jf2ss863v0wpvvhrkaivqzhy6af9m9zwvw0p0k"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -498,22 +498,7 @@ transactions from C or Python.")
                   (add-after 'unpack 'dependency-on-python-magic
                     (lambda _
                       (substitute* "setup.py"
-                        (("'python-magic',") ""))))
-                  ;; The test suite assumes we have pytest >= 2.9.0.
-                  ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=841146
-                  (add-after 'unpack 'disable-failing-test
-                    (lambda _
-                      (substitute* "tests/comparators/utils.py"
-                        (("skip\\(reason\\=\\\"requires \\{\\}\\\"\\.format\\(tool\\)\\)")
-                          "skipif(True, reason=\"Requires pytest >= 2.9\")"))))
-                  (add-before 'build 'disable-egg-zipping
-                    (lambda _
-                      ;; Leave the .egg file uncompressed.
-                      (let ((port (open-file "setup.cfg" "a")))
-                        (display "\n[easy_install]\nzip_ok = 0\n"
-                                 port)
-                        (close-port port)
-                        #t))))))
+                        (("'python-magic',") "")))))))
     (inputs `(("rpm" ,rpm)                        ;for rpm-python
               ("python-file" ,python-file)
               ("python-debian" ,python-debian)