summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-04-09 22:21:37 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-04-11 00:49:55 +0530
commitb247fb86ac5d406368fbc30e9ba516cd01143d48 (patch)
tree0b80cbd38b4ea5eb67eb82b0aad8d824714f30dc /gnu
parent0201c5d41ecda9b55d4217b31ef6efa1c78b5a25 (diff)
downloadguix-b247fb86ac5d406368fbc30e9ba516cd01143d48.tar.gz
gnu: Add emacs-use-package.
* gnu/packages/emacs.scm (emacs-use-package): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index e9e56ee280..ff33daf71d 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4102,3 +4102,38 @@ actually changing the buffer's text.")
     (description "@code{emacs-diminish} implements hiding or
 abbreviation of the mode line displays (lighters) of minor modes.")
     (license license:gpl2+)))
+
+(define-public emacs-use-package
+  (package
+    (name "emacs-use-package")
+    (version "2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/jwiegley/use-package/archive/"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0x4h136jb3imyli6zsh7dyzjrra6pv0v6b0yk94jdng3rdfcmsf5"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-diminish" ,emacs-diminish)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'check
+           (lambda _
+             (zero? (system* "emacs" "--batch" "-L" "."
+                             "-l" "use-package-tests.el"
+                             "-f" "ert-run-tests-batch-and-exit"))
+             ;; Tests fail in this release, but have been fixed in
+             ;; upstream commit 7956d40eed57d6c06bef36ebc174cf57d934e30d
+             #t)))))
+    (home-page "https://github.com/jwiegley/use-package")
+    (synopsis "Declaration for simplifying your .emacs")
+    (description "The use-package macro allows you to isolate package
+configuration in your @file{.emacs} file in a way that is both
+performance-oriented and tidy.")
+    (license license:gpl2+)))