summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2020-12-29 13:41:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-29 14:39:55 +0100
commitb32b625f0ab44fbd07804359979995cd3647712b (patch)
tree15d218992b51fd092d86d63cd226e41d3a118141 /gnu
parentdd35b58ce3baec62298e77a9484fffbbcb19b31c (diff)
downloadguix-b32b625f0ab44fbd07804359979995cd3647712b.tar.gz
gnu: Add r-paradox.
* gnu/packages/cran.scm (r-paradox): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 527412b365..3604ebd06b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25460,3 +25460,28 @@ helper functions for functional programming, for printing, to work with
 @code{data.table}, as well as some generally useful @code{R6} classes.  This
 package also supersedes the package @code{BBmisc}.")
     (license license:lgpl3)))
+
+(define-public r-paradox
+  (package
+    (name "r-paradox")
+    (version "0.6.0")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "paradox" version))
+              (sha256
+               (base32
+                "1zv0q411wcwigkf4yggs3w2gz48lvv3jhnrddrv40qih8b70ywi3"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-backports" ,r-backports)
+       ("r-checkmate" ,r-checkmate)
+       ("r-data-table" ,r-data-table)
+       ("r-mlr3misc" ,r-mlr3misc)
+       ("r-r6" ,r-r6)))
+    (home-page "https://paradox.mlr-org.com/")
+    (synopsis "Define and work with parameter spaces for complex algorithms")
+    (description "With this package it is possible to define parameter spaces,
+constraints and dependencies for arbitrary algorithms, and to program on such
+spaces.  It also includes statistical designs and random samplers.  Objects are
+implemented as @code{R6} classes.")
+    (license license:lgpl3)))