summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-22 16:21:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-24 11:10:55 +0200
commitb355c4272d93a1b2708fe5e723dc72792bfaf64e (patch)
tree94153550218c7c6029584d0a5694c2307bceaa69 /gnu
parentc25e7e514724cd880ee738fa987245acc192ff3a (diff)
downloadguix-b355c4272d93a1b2708fe5e723dc72792bfaf64e.tar.gz
gnu: Add texlive-nrc.
* gnu/packages/tex.scm (texlive-nrc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fb650af166..46461bcf73 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23306,6 +23306,27 @@ index style file.  The style serves both for printed and for electronic
 books.")
     (license license:lppl)))
 
+(define-public texlive-nrc
+  (package
+    (name "texlive-nrc")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/nrc/" "source/latex/nrc/"
+                   "tex/latex/nrc/")
+             (base32
+              "10h5adzwj8558rwgwipjsbq4j5h674v8nrqfp6hvs3wbn8gdd9hj")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/nrc")
+    (synopsis "Class for the NRC technical journals")
+    (description
+     "This package provides macros, and some documentation, for typesetting
+papers for submission to journals published by the National Research Council
+Research Press.  At present, only @file{nrc2.cls} (for two-column layout)
+should be used.")
+    (license license:lppl)))
+
 (define-public texlive-nucleardata
   (package
     (name "texlive-nucleardata")