summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-31 22:56:22 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-31 22:58:27 +0200
commitb4a330ac721bd7682066cfd246f2084368a364f2 (patch)
treeb539d31a17bcbc9e39d3d549e29f1f9ad24d8eac /gnu
parent2a74f6f7e72c0bc420316d0d7cfb72bdcaedf414 (diff)
downloadguix-b4a330ac721bd7682066cfd246f2084368a364f2.tar.gz
gnu: wine: Add support for armhf and aarch64.
* gnu/packages/wine.scm (wine)[arguments]: Target armhf-linux when
building on armhf or aarch64.
[supported-systems]: Add armhf and aarch64 to supported systems.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wine.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 2c7732bcf3..d5309fd986 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -55,7 +55,8 @@
   #:use-module (gnu packages tls)
   #:use-module (gnu packages video)
   #:use-module (gnu packages xml)
-  #:use-module (gnu packages xorg))
+  #:use-module (gnu packages xorg)
+  #:use-module (ice-9 match))
 
 (define-public wine
   (package
@@ -113,9 +114,13 @@
        ("v4l-utils" ,v4l-utils)
        ("zlib" ,zlib)))
     (arguments
-     `(;; Force a 32-bit build (under the assumption that this package is
-       ;; being used on an IA32-compatible architecture.)
-       #:system "i686-linux"
+     `(;; Force a 32-bit build targeting a similar architecture, i.e.:
+       ;; armhf for armhf/aarch64, i686 for i686/x86_64.
+       #:system ,@(match (%current-system)
+                    ((or "armhf-linux" "aarch64-linux")
+                     `("armhf-linux"))
+                    (_
+                     `("i686-linux")))
 
        ;; XXX: There's a test suite, but it's unclear whether it's supposed to
        ;; pass.
@@ -154,7 +159,7 @@ integrate Windows applications into your desktop.")
 
     ;; It really only supports IA32, but building on x86_64 will have the same
     ;; effect as building on i686 anyway.
-    (supported-systems '("i686-linux" "x86_64-linux"))))
+    (supported-systems (delete "mips64el-linux" %supported-systems))))
 
 (define-public wine64
   (package