summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros@foradis.org>2017-09-09 20:57:47 +0300
committerLudovic Courtès <ludo@gnu.org>2017-10-11 11:12:33 +0200
commitb509efb385e25e19bd1a44352c221ce74e961cff (patch)
tree5a5b9cad8d50b81d803ad3c325c30ff87097de9f /gnu
parent22d1060eff9df7086beef8ea3aa2158106f97de7 (diff)
downloadguix-b509efb385e25e19bd1a44352c221ce74e961cff.tar.gz
gnu: Add lapack-3.5.
* gnu/packages/maths.scm (lapack-3.5): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index add67d45a8..69f2e4e33b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -473,6 +473,19 @@ problems in numerical linear algebra.")
     (license (license:non-copyleft "file://LICENSE"
                                 "See LICENSE in the distribution."))))
 
+(define-public lapack-3.5
+  (package
+    (inherit lapack)
+    (version "3.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://www.netlib.org/lapack/lapack-"
+                           version ".tgz"))
+       (sha256
+        (base32
+         "0lk3f97i9imqascnlf6wr5mjpyxqcdj73pgj97dj2mgvyg9z1n4s"))))))
+
 (define-public scalapack
   (package
     (name "scalapack")