summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-11-05 15:23:05 -0500
committerJohn Kehayias <john.kehayias@protonmail.com>2023-11-05 22:09:45 -0500
commitb5915131ae16c237c82f671f5a932976fe6fa8a7 (patch)
treea66eadedc83582ed73d9319cf8a4fdfcd918ef78 /gnu
parentbfbea553e7aad43cd7b853e6e2737950b97ec0b6 (diff)
downloadguix-b5915131ae16c237c82f671f5a932976fe6fa8a7.tar.gz
gnu: nghttp2: Update to 1.58.0 and ungraft.
* gnu/packages/web.scm (nghttp2): Update to 1.58.0.
[replacement]: Remove.
(nghttp2-1.57): Remove variable.

Change-Id: I737253295d6b3a832156acc8736167ee1ab470eb
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 66d09700db..f323058c33 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7958,8 +7958,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
 (define-public nghttp2
   (package
     (name "nghttp2")
-    (version "1.49.0")
-    (replacement nghttp2-1.57)
+    (version "1.58.0")
     (source
      (origin
        (method url-fetch)
@@ -7968,7 +7967,7 @@ derivation by David Revoy from the original MonsterID by Andreas Gohr.")
                            "nghttp2-" version ".tar.xz"))
        (sha256
         (base32
-         "0vm692c7q2wc4xxz8c41nr8jps2fkwf51xp8fb233cghpf9d9kxh"))))
+         "1q4ps8acr7nyia7mf2z11m0yh3fn1imhyv855j3xjbx91l2a6s2a"))))
     (build-system gnu-build-system)
     (outputs (list "out"
                    "lib"))              ; only libnghttp2
@@ -8070,19 +8069,6 @@ compressed JSON header blocks.
                    (("print \\(ver >= '3\\.8'\\)")
                     "print (tuple(map(int, ver.split('.'))) >= (3,8))")))))))))))
 
-(define-public nghttp2-1.57
-  (package
-    (inherit nghttp2)
-    (version "1.57.0")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/nghttp2/nghttp2/"
-                                  "releases/download/v" version "/"
-                                  "nghttp2-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0n598w7w8rqdqiay2fad3a11253hibakan5c4vjkpx09648v044j"))))))
-
 (define-public hpcguix-web
   (package
     (name "hpcguix-web")