summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:04:07 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:07:13 +0200
commitb686b39cf503bb9fd7215a506f7ac341e7db7482 (patch)
tree9194474328f4bdae7aecf16cd0d2c9f35fb02979 /gnu
parent6be8b104b6a51ccd8712a8bd2f09db553021bc3b (diff)
downloadguix-b686b39cf503bb9fd7215a506f7ac341e7db7482.tar.gz
gnu: Add texlive-unravel.
* gnu/packages/tex.scm (texlive-unravel): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bdf8124ac5..bd002a3b1e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -99017,6 +99017,28 @@ another unit.  Supported are all TeX related units, and also @samp{km} and
 package only works with LuaLaTeX.")
     (license license:lppl1.3+)))
 
+(define-public texlive-unravel
+  (package
+    (name "texlive-unravel")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/unravel/" "source/latex/unravel/"
+                   "tex/latex/unravel/")
+             (base32
+              "0d80axwfyc73q92vcazmkvlk69g1fqx986gcncpqpc11a81y10qa")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/unravel")
+    (synopsis "Watching TeX digest tokens")
+    (description
+     "The aim of this LaTeX package is to help debug complicated macros.  This is
+done by letting the user step through the execution of some TeX code, going
+through the details of nested expansions, performing assignments, as well as
+some simple typesetting commands.  To use this package, one should normally
+run TeX in a terminal.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar