summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-15 09:53:19 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:46 +0200
commitb7a062bf104be21800d828f7b645388959fd52f2 (patch)
tree775cfdb5eeaa4fe15435c910d00f3fc562de4e34 /gnu
parent4d4bcff701714081c7a9bfafec2abb90837a9ad0 (diff)
downloadguix-b7a062bf104be21800d828f7b645388959fd52f2.tar.gz
gnu: Add rust-grep-regex-0.1.
* gnu/packages/crates-io.scm (rust-grep-regex-0.1): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 201e1a2251..e383088463 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -3459,6 +3459,36 @@ the regex engine it uses pluggable.")
     (description "Use PCRE2 with the grep crate.")
     (license (list license:expat license:unlicense))))
 
+(define-public rust-grep-regex-0.1
+  (package
+    (name "rust-grep-regex")
+    (version "0.1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "grep-regex" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1lbb8837gzy25n706mnidaps4jl63ym679zraj8nfy5g02zbz549"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-aho-corasick" ,rust-aho-corasick-0.7)
+        ("rust-grep-matcher" ,rust-grep-matcher-0.1)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-regex" ,rust-regex-1.1)
+        ("rust-regex-syntax" ,rust-regex-syntax-0.6)
+        ("rust-thread-local" ,rust-thread-local-0.3)
+        ("rust-utf8-ranges" ,rust-utf8-ranges-1.0))))
+    (home-page "https://github.com/BurntSushi/ripgrep")
+    (synopsis "Use Rust's regex library with the grep crate")
+    (description
+     "Use Rust's regex library with the grep crate.")
+    (license (list license:unlicense license:expat))))
+
 (define-public rust-half-1.3
   (package
     (name "rust-half")