summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-05-19 01:40:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-05-19 01:41:00 +0200
commitb7c7a61dd614beeaa9329cf5cf98561adc4f4b06 (patch)
treef60ec497c0cf657b5d659db1bea74e563e7f417e /gnu
parent687adf00dd2583eef66bdec0a15b629281c30819 (diff)
downloadguix-b7c7a61dd614beeaa9329cf5cf98561adc4f4b06.tar.gz
gnu: Add guile-netlink.
* gnu/package/guile-xyz.scm (guile-netlink): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 3d85b54488..4473aed79d 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4742,3 +4742,37 @@ in a large number of randomly generated test cases.")
      "This package contains helper functions for working with file system
 locations.")
     (license license:agpl3+)))
+
+(define-public guile-netlink
+  (package
+    (name "guile-netlink")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://git.lepiller.eu/git/guile-netlink")
+              (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "03zmsha2d7whlwb52gna83jdas9bqi18rq3sss7kkicv814qb35g"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f)); no tests
+    (inputs
+     `(("guile" ,guile-3.0)))
+    (native-inputs
+     `(("automake" ,automake)
+       ("autoconf" ,autoconf)
+       ("pkg-config" ,pkg-config)
+       ("texinfo" ,texinfo)))
+    (home-page "https://git.lepiller.eu/guile-netlink")
+    (synopsis "Netlink protocol implementation for Guile")
+    (description "Guile Netlink is a GNU Guile library providing an implementation
+of the netlink protocol.
+
+It provides a generic library for writing implementations of a netlink
+protocol, a low-level rtnetlink implementation that uses that library and a
+high-level API for network management that uses rtnetlink.")
+    (license license:gpl3+)))