summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-02-27 12:00:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-02-27 16:25:26 +0100
commitb951e26fe564ce47ff2592c120249643d00b2149 (patch)
treeab7b01923baed6f0247c461563a9691831f159b9 /gnu
parentb35461748b20d0172744974b39e7d9d033400c51 (diff)
downloadguix-b951e26fe564ce47ff2592c120249643d00b2149.tar.gz
gnu: arandr: Add "xrandr" to inputs.
* gnu/packages/xdisorg.scm (arandr)[inputs]: Add "xrandr".
[arguments]: Add build phase "make-xrandr-available" to ensure "xrandr"
executable is found at runtime.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d72f9f80c6..5a77a6c8f3 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2015 xd1le <elisp.vim@gmail.com>
 ;;; Copyright © 2015 Florian Paul Schmidt <mista.tapas@gmx.net>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -66,9 +67,20 @@
                (base32
                 "0d574mbmhaqmh7kivaryj2hpghz6xkvic9ah43s1hf385y7c33kd"))))
     (build-system python-build-system)
-    (arguments `(#:python ,python-2     ;incompatible with python 3
-                 #:tests? #f))          ;no tests
-    (inputs `(("pygtk" ,python2-pygtk)))
+    (arguments
+     `(#:python ,python-2     ;incompatible with python 3
+       #:tests? #f ;no tests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'make-xrandr-available
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (wrap-program (string-append (assoc-ref outputs "out")
+                                          "/bin/arandr")
+               `("PATH" ":" prefix (,(string-append (assoc-ref inputs "xrandr")
+                                                    "/bin"))))
+             #t)))))
+    (inputs `(("pygtk" ,python2-pygtk)
+              ("xrandr" ,xrandr)))
     (native-inputs `(("gettext"           ,gnu-gettext)
                      ("python-docutils"   ,python2-docutils)
                      ("python-setuptools" ,python2-setuptools)))