summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-04-08 16:59:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-11 16:11:45 +0200
commitb96c0b051dc427c4e1c0fbaa2878a7629a5ce2e3 (patch)
tree4bd25bc984c742b0d6cd9c509b0a701afe8ba09e /gnu
parent7cd1dd3e105341df7c72d67f45df6a872be865ba (diff)
downloadguix-b96c0b051dc427c4e1c0fbaa2878a7629a5ce2e3.tar.gz
gnu: Add r-dlm.
* gnu/packages/cran.scm (r-dlm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8a7d98cf30..24be945e74 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -659,6 +659,26 @@ size and can be easily tested locally before being sent to a remote.")
 the system clipboards.")
     (license license:gpl3)))
 
+(define-public r-dlm
+  (package
+    (name "r-dlm")
+    (version "1.1-5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dlm" version))
+       (sha256
+        (base32 "1aksm66sfa7ipl5xgs4j5giac7q2m744wjl40mva56xn6i674h4r"))))
+    (properties `((upstream-name . "dlm")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/package=dlm")
+    (synopsis "Bayesian and Likelihood Analysis of Dynamic Linear Models")
+    (description
+     "This package provides routines for Maximum likelihood, Kalman filtering
+and smoothing, and Bayesian analysis of Normal linear State Space models, also
+known as Dynamic Linear Models.")
+    (license license:gpl2+)))
+
 (define-public r-zoo
   (package
     (name "r-zoo")