summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 20:27:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:25 +0200
commitba40456e864fcfabdc33be0325503b073603fe9c (patch)
tree665b9a5e96f4d0a7c57ef95a7934285b32220592 /gnu
parent0d66aa4a9d6b5f89c1edc28bd3706069b44eb631 (diff)
downloadguix-ba40456e864fcfabdc33be0325503b073603fe9c.tar.gz
gnu: rust-core-text: Move to (gnu packages crates-apple).
* gnu/packages/crates-io.scm (rust-core-text-20, rust-core-text-19):
Move from here ...
* gnu/packages/crates-apple.scm: ... to here.

Change-Id: Idbad69dd6e1bcbff80e6cb3ce699120edb5fa25c
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-apple.scm45
-rw-r--r--gnu/packages/crates-io.scm43
2 files changed, 44 insertions, 44 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 9cec1826ed..7e4d1ee543 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019, 2020, 2023, 2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Valentin Ignatev <valentignatev@gmail.com>
-;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2023 Steve George <steve@futurile.net>
@@ -322,3 +322,46 @@ extension of blocks.")
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-libc" ,rust-libc-0.2))))))
+
+(define-public rust-core-text-20
+  (package
+    (name "rust-core-text")
+    (version "20.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "core-text" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1mffma8w0ic11ydv6zclamw4dslzmsych1fwz14msih8bh5pkln9"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t ; link kind `framework` is only supported on Apple targets
+       #:cargo-inputs (("rust-core-foundation" ,rust-core-foundation-0.9)
+                       ("rust-core-graphics" ,rust-core-graphics-0.23)
+                       ("rust-foreign-types" ,rust-foreign-types-0.5)
+                       ("rust-libc" ,rust-libc-0.2))))
+    (home-page "https://github.com/servo/core-foundation-rs")
+    (synopsis "Bindings to the Core Text framework")
+    (description "This package provides bindings to the Core Text framework.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-core-text-19
+  (package
+    (inherit rust-core-text-20)
+    (name "rust-core-text")
+    (version "19.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "core-text" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0q1sr55v8zq82y0dwnwwksz1radh515i0a45nbsda3w2idpg9iyj"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-core-foundation" ,rust-core-foundation-0.9)
+        ("rust-core-graphics" ,rust-core-graphics-0.22)
+        ("rust-foreign-types" ,rust-foreign-types-0.3)
+        ("rust-libc" ,rust-libc-0.2))))))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b0dbf6ca5a..b1235909ab 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -14837,49 +14837,6 @@ in @code{no_std}.  Alloc support is optional.")
 intrinsics.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-core-text-20
-  (package
-    (name "rust-core-text")
-    (version "20.1.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "core-text" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1mffma8w0ic11ydv6zclamw4dslzmsych1fwz14msih8bh5pkln9"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t ; link kind `framework` is only supported on Apple targets
-       #:cargo-inputs (("rust-core-foundation" ,rust-core-foundation-0.9)
-                       ("rust-core-graphics" ,rust-core-graphics-0.23)
-                       ("rust-foreign-types" ,rust-foreign-types-0.5)
-                       ("rust-libc" ,rust-libc-0.2))))
-    (home-page "https://github.com/servo/core-foundation-rs")
-    (synopsis "Bindings to the Core Text framework")
-    (description "This package provides bindings to the Core Text framework.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-core-text-19
-  (package
-    (inherit rust-core-text-20)
-    (name "rust-core-text")
-    (version "19.1.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "core-text" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0q1sr55v8zq82y0dwnwwksz1radh515i0a45nbsda3w2idpg9iyj"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-core-foundation" ,rust-core-foundation-0.9)
-        ("rust-core-graphics" ,rust-core-graphics-0.22)
-        ("rust-foreign-types" ,rust-foreign-types-0.3)
-        ("rust-libc" ,rust-libc-0.2))))))
-
 (define-public rust-cov-mark-2
   (package
     (name "rust-cov-mark")