summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:44:40 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:24:37 +0200
commitbb87be09a972c41bc4c0c8b5758b2abac2312750 (patch)
tree8d90001c653c989f0905578e85a138d3c385b402 /gnu
parentd6e559ab291b781a67376beabbb5fa666fcd309c (diff)
downloadguix-bb87be09a972c41bc4c0c8b5758b2abac2312750.tar.gz
gnu: Add ghc-stm-chans.
* gnu/packages/haskell.scm (ghc-stm-chans): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6891703c19..61ee78e42f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8864,4 +8864,26 @@ Foundation has the following goals:
 @end enumerate\n")
     (license license:bsd-3)))
 
+(define-public ghc-stm-chans
+  (package
+    (name "ghc-stm-chans")
+    (version "3.0.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "stm-chans-" version "/"
+                           "stm-chans-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0f27sp09yha43xk9q55sc185jyjs5h7gq2dhsyx6bm9kz9dzqi13"))))
+    (build-system haskell-build-system)
+    (inputs `(("ghc-stm" ,ghc-stm)))
+    (home-page "https://hackage.haskell.org/package/stm-chans")
+    (synopsis "Additional types of channels for ghc-stm")
+    (description "This Haskell package offers a collection of channel types,
+similar to @code{Control.Concurrent.STM.@{TChan,TQueue@}} but with additional
+features.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here