summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-20 16:37:01 +0100
committerMarius Bakke <marius@gnu.org>2022-11-20 17:54:04 +0100
commitbb9837f66cc06373a6bc513b85ce2816fe36d58e (patch)
treec10a33cdd2d5df34f338c0c693745c24b64aba8e /gnu
parentda6c6763fa72585a1df3021781f8d33c3b64dcc8 (diff)
downloadguix-bb9837f66cc06373a6bc513b85ce2816fe36d58e.tar.gz
gnu: postgresql: Add 15.1.
* gnu/packages/databases.scm (postgresql-15): New variable.
(postgresql-14): Inherit from it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/databases.scm19
1 files changed, 16 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index afadc5373c..2664142779 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1222,17 +1222,17 @@ and high-availability (HA).")
     (license license:gpl2)))                  ;'COPYING' says "version 2" only
 
 ;; Don't forget to update the other postgresql packages when upgrading this one.
-(define-public postgresql-14
+(define-public postgresql-15
   (package
     (name "postgresql")
-    (version "14.4")
+    (version "15.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://ftp.postgresql.org/pub/source/v"
                                   version "/postgresql-" version ".tar.bz2"))
               (sha256
                (base32
-                "0slg7ld5mldmv3pn1wxxwglm4s3xc6c91ixx24apj713qlvn4fy2"))
+                "1bi19sqmri569hyjvbk8grlws7f5dalsqz87wkgx1yjafcyz5zb4"))
               (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -1284,6 +1284,19 @@ TIMESTAMP.  It also supports storage of binary large objects, including
 pictures, sounds, or video.")
     (license (license:x11-style "file://COPYRIGHT"))))
 
+(define-public postgresql-14
+  (package
+    (inherit postgresql-15)
+    (name "postgresql")
+    (version "14.4")
+    (source (origin
+              (inherit (package-source postgresql-15))
+              (uri (string-append "https://ftp.postgresql.org/pub/source/v"
+                                  version "/postgresql-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "0slg7ld5mldmv3pn1wxxwglm4s3xc6c91ixx24apj713qlvn4fy2"))))))
+
 (define-public postgresql-13
   (package
     (inherit postgresql-14)