summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-08-23 18:24:08 +0800
committer宋文武 <iyzsong@gmail.com>2015-08-23 18:41:25 +0800
commitbcb354ad94daaa16f710062dcbf1f979495a29f1 (patch)
treeedd1ad82330599c33c6f069d3074c6cc877c1f6a /gnu
parenta63a73dcb7a8bec81c8e2e30fc6e8f4b570fd495 (diff)
downloadguix-bcb354ad94daaa16f710062dcbf1f979495a29f1.tar.gz
gnu: Fix build failures due to missing XMLLINT.
This is a followup to commit 4b58d88.

* gnu/packages/gnome.scm (eog, epiphany, evince, gnome-desktop,
  gnome-klotski, gnome-mines, gnome-terminal, rhythmbox, seahorse,
  simple-scan, totem): Add LIBXML2 to native-inputs.
  (evince, gnome-desktop, rhythmbox): Move ITSTOOL to native-inputs.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm46
1 files changed, 28 insertions, 18 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4b26066379..b392399157 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -174,15 +174,16 @@ commonly used macros.")
         "05lvik5cdh51xqd332qingph09zdhiaa1kqy9k2sk1simz4pvf8m"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("intltool" ,intltool)
-       ("pkg-config" ,pkg-config)))
+     `(("itstool" ,itstool)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (inputs
      `(("gdk-pixbuf" ,gdk-pixbuf)
        ("glib" ,glib)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gtk+" ,gtk+)
        ("iso-codes" ,iso-codes)
-       ("itstool" ,itstool)
        ("libx11" ,libx11)
        ("libxext" ,libxext)
        ("libxkbfile" ,libxkbfile)
@@ -408,7 +409,6 @@ forgotten when the session ends.")
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("libgnome-keyring" ,libgnome-keyring)
        ("adwaita-icon-theme" ,adwaita-icon-theme)
-       ("itstool" ,itstool)
        ("gdk-pixbuf" ,gdk-pixbuf)
        ("atk" ,atk)
        ("pango" ,pango)
@@ -421,13 +421,14 @@ forgotten when the session ends.")
        ("dconf" ,dconf)
        ("libcanberra" ,libcanberra)
        ("libsecret" ,libsecret)
-
        ;; For tests.
        ("dogtail" ,python2-dogtail)))
     (native-inputs
-     `(("intltool" ,intltool)
+     `(("itstool" ,itstool)
+       ("intltool" ,intltool)
        ("glib" ,glib "bin")
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (home-page
      "http://www.gnome.org/projects/evince/")
     (synopsis "GNOME's document viewer")
@@ -1607,7 +1608,8 @@ engineering.")
      `(("intltool" ,intltool)
        ("glib:bin" ,glib "bin")
        ("itstool" ,itstool)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (home-page "https://launchpad.net/gnome-themes-standard")
     (synopsis "Manage encryption keys and passwords in the GNOME keyring")
     (description
@@ -2089,7 +2091,8 @@ and other secrets.  It communicates with the \"Secret Service\" using DBus.")
      `(("pkg-config" ,pkg-config)
        ("desktop-file-utils" ,desktop-file-utils)
        ("intltool" ,intltool)
-       ("itstool" ,itstool)))
+       ("itstool" ,itstool)
+       ("xmllint" ,libxml2)))
     (inputs
      `(("gtk+" ,gtk+)
        ("librsvg" ,librsvg)))
@@ -2128,7 +2131,8 @@ floating in an ocean using only your brain and a little bit of luck.")
      `(("pkg-config" ,pkg-config)
        ("desktop-file-utils" ,desktop-file-utils)
        ("intltool" ,intltool)
-       ("itstool" ,itstool)))
+       ("itstool" ,itstool)
+       ("xmllint" ,libxml2)))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (inputs
@@ -2764,7 +2768,8 @@ queries upon that data.")
      `(("desktop-file-utils" ,desktop-file-utils)
        ("intltool" ,intltool)
        ("itstool" ,itstool)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (inputs
      `(("gtk+" ,gtk+)
        ("librsvg" ,librsvg)))
@@ -2899,7 +2904,8 @@ for application developers.")
        ("desktop-file-utils" ,desktop-file-utils)
        ("gobject-introspection" ,gobject-introspection)
        ("intltool" ,intltool)
-       ("itstool" ,itstool)))
+       ("itstool" ,itstool)
+       ("xmllint" ,libxml2)))
     (propagated-inputs
      `(("dconf" ,dconf)))
     (inputs
@@ -2996,11 +3002,13 @@ which can read a large number of file formats.")
    (propagated-inputs
     `(("dconf" ,dconf)))
    (native-inputs
-    `(("intltool" ,intltool)
+    `(("itstool" ,itstool)
+      ("intltool" ,intltool)
       ("glib" ,glib "bin")
       ("gobject-introspection" ,gobject-introspection)
       ("desktop-file-utils" ,desktop-file-utils)
-      ("pkg-config" ,pkg-config)))
+      ("pkg-config" ,pkg-config)
+      ("xmllint" ,libxml2)))
    (inputs
     `(("json-glib" ,json-glib)
       ("tdb" ,tdb)
@@ -3010,7 +3018,6 @@ which can read a large number of file formats.")
       ("vala" ,vala)
       ("gmime" ,gmime)
       ("nettle" ,nettle)
-      ("itstool" ,itstool)
       ("adwaita-icon-theme" ,adwaita-icon-theme)
       ("grilo" ,grilo)
       ("grilo-plugins" ,grilo-plugins)
@@ -3075,7 +3082,8 @@ supports playlists, song ratings, and any codecs installed through gstreamer.")
       ("itstool", itstool)
       ("glib" ,glib "bin")
       ("gobject-introspection" ,gobject-introspection)
-      ("pkg-config" ,pkg-config)))
+      ("pkg-config" ,pkg-config)
+      ("xmllint" ,libxml2)))
    (inputs
     `(("gnome-desktop" ,gnome-desktop)
       ("shared-mime-info" ,shared-mime-info)
@@ -3246,7 +3254,8 @@ USB transfers with your high-level application or system daemon.")
        ("colord" ,colord)
        ("glib" ,glib "bin")                       ; glib-compile-schemas, etc.
        ("pkg-config" ,pkg-config)
-       ("vala" ,vala)))
+       ("vala" ,vala)
+       ("xmllint" ,libxml2)))
     (home-page "https://launchpad.net/simple-scan")
     (synopsis "Document and image scanner")
     (description "Simple Scan is an easy-to-use application, designed to let
@@ -3281,7 +3290,8 @@ work and the interface is well tested.")
     (native-inputs
      `(("intltool" ,intltool)
        ("itstool" ,itstool)
-       ("pkg-config" ,pkg-config)))
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
     (inputs
      `(("avahi" ,avahi)
        ("gcr" ,gcr)