summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSteve George <steve@futurile.net>2023-10-23 23:20:50 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-10-24 14:25:49 +0300
commitbcbcba19a8a2f4a312b8da8234bc1778a3214f69 (patch)
tree704b3b8a26de9367fafef47cac72136ca7602a6d /gnu
parentfc62986a50fcf9c3800f6ffca37176b673b95a63 (diff)
downloadguix-bcbcba19a8a2f4a312b8da8234bc1778a3214f69.tar.gz
gnu: Add rust-rental-0.5.
* gnu/packages/crates-io.scm (rust-rental-0.5): New variable.
(rust-rental-impl-0.5): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Change-Id: I03878fc540be2aced8c3952d7d78275c0b0c3e54
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index f94526c8a2..6f1da5a6bc 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -56777,6 +56777,55 @@ crate unless you're working on a regex implementation.")
 Rust.")
     (license license:expat)))
 
+(define-public rust-rental-0.5
+  (package
+    (name "rust-rental")
+    (version "0.5.6")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rental" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0bhzz2pfbg0yaw8p1l31bggq4jn077wslf6ifhj22vf3r8mgx2fc"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:tests? #f  ; cannot move out of `foo` because it is borrowed
+           #:cargo-inputs
+           `(("rust-rental-impl" ,rust-rental-impl-0.5)
+             ("rust-stable-deref-trait" ,rust-stable-deref-trait-1))))
+    (home-page "https://github.com/jpernst/rental")
+    (synopsis "Macro to generate safe self-referential structs")
+    (description
+     "A macro to generate safe self-referential structs, plus
+premade types for common use-cases.  This crate is frozen and should be
+avoided if possible.")
+    (license (list license:expat license:asl2.0))))
+
+(define-public rust-rental-impl-0.5
+  (package
+    (name "rust-rental-impl")
+    (version "0.5.5")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rental-impl" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1pj0qgmvwwsfwyjqyjxzikkwbwc3vj7hm3hdykr47dy5inbnhpj7"))))
+    (build-system cargo-build-system)
+    (arguments
+     (list #:skip-build? #f
+           #:cargo-inputs
+           `(("rust-proc-macro2" ,rust-proc-macro2-1)
+             ("rust-quote" ,rust-quote-1)
+             ("rust-syn" ,rust-syn-1))))
+    (home-page "https://github.com/jpernst/rental")
+    (synopsis "Implementation details of the rust-rental crate")
+    (description "Implementation details for the rust-rental crate.
+Should not be used directly.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-reopen-0.3
   (package
     (name "rust-reopen")