summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-04-10 23:19:44 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-12 08:29:37 -0400
commitbcc2cd5fefa365a615a926dfa5fa564b793ec527 (patch)
tree6c57c6347f0410fd5d2b2289d20da6293a008ac1 /gnu
parent2bad43d1c2797bf9a3ec0364210bd3702a1f578f (diff)
downloadguix-bcc2cd5fefa365a615a926dfa5fa564b793ec527.tar.gz
gnu: libconfig: Replace config script helpers.
* gnu/packages/textutils.scm (libconfig)[arguments]: Add phase to
replace config.guess, config.sub.
[native-inputs]: Add config.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/textutils.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index fb8bc7e868..d7cb217e17 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2016, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2018, 2019, 2020, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Nikita <nikita@n0.is>
 ;;; Copyright © 2016, 2020 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
@@ -527,6 +527,20 @@ character-by-character.
                (base32
                 "1rqynfxl1zxwk4b42sniz9xlw285aidcrsfih51p8dy0rbb6clal"))))
     (build-system gnu-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-after 'unpack 'update-config-scripts
+             (lambda* (#:key native-inputs inputs #:allow-other-keys)
+               (for-each (lambda (file)
+                           (install-file
+                             (search-input-file
+                               (or native-inputs inputs)
+                               (string-append "/bin/" file)) "aux-build"))
+                         '("config.guess" "config.sub")))))))
+    (native-inputs
+     (list config))
     (synopsis "C/C++ configuration file library")
     (description
      "Libconfig is a simple library for manipulating structured configuration