summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-03-09 21:30:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-09 22:05:24 +0100
commitbcdf0cf3a59287db5716359998fd124dcc1d83c2 (patch)
tree2cfb126facca595c6773230880916d71a20385ed /gnu
parent3c04e179b7dc86bb6af5d6b7aec63430885e1c6a (diff)
downloadguix-bcdf0cf3a59287db5716359998fd124dcc1d83c2.tar.gz
gnu: Add r-rstpm2.
* gnu/packages/cran.scm (r-rstpm2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c9d65a0efd..e00b611a83 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1366,6 +1366,39 @@ data structures in C++.")
 rules and utility functions for adaptive GH quadrature.")
     (license license:expat)))
 
+(define-public r-rstpm2
+  (package
+    (name "r-rstpm2")
+    (version "1.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "rstpm2" version))
+       (sha256
+        (base32
+         "0c6l3z250b2kn6mh2xyb0bd2y5nsbj11n9xfi51dac9s8xq3v7m4"))))
+    (properties `((upstream-name . "rstpm2")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bbmle" ,r-bbmle)
+       ("r-bh" ,r-bh)
+       ("r-desolve" ,r-desolve)
+       ("r-fastghquad" ,r-fastghquad)
+       ("r-mgcv" ,r-mgcv)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-survival" ,r-survival)))
+    (native-inputs
+     `(("gfortran" ,gfortran)))
+    (home-page "https://github.com/mclements/rstpm2")
+    (synopsis "Link-based survival models")
+    (description
+     "This package provides R implementations of @dfn{generalized survival
+models} (GSMs), smooth @dfn{accelerated failure time} (AFT) models and Markov
+multi-state models.")
+    ;; One of these licenses
+    (license (list license:gpl2 license:gpl3))))
+
 ;; This package includes minified JavaScript files.  When upgrading please
 ;; check that there are no new minified JavaScript files.
 (define-public r-jquerylib