summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:01:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 12:10:03 +0300
commitbdcb84578d1ea94523dbca10fb6f8c136fac60f1 (patch)
tree78582673cb5f0ec40dde4aa8e71696375d4a1797 /gnu
parent41eb9da3886af857088b95ebadaa38fa173cd459 (diff)
downloadguix-bdcb84578d1ea94523dbca10fb6f8c136fac60f1.tar.gz
gnu: Add python-rcssmin.
* gnu/packages/python-xyz.scm (python-rcssmin): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e16d3daf54..510729bea8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13545,6 +13545,30 @@ network.")
 (define-public python2-argcomplete
   (package-with-python2 python-argcomplete))
 
+(define-public python-rcssmin
+  (package
+    (name "python-rcssmin")
+    (version "1.0.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "rcssmin" version))
+        (sha256
+         (base32
+          "0w42l4dhxghcz7pj3q7hkxp015mvb8z2cq9sfxbl31npsfavd1ya"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "run_tests.py" "tests"))))))
+    (home-page "http://opensource.perlig.de/rcssmin/")
+    (synopsis "CSS Minifier")
+    (description "The minifier is based on the semantics of the YUI compressor,
+which itself is based on the rule list by Isaac Schlueter.")
+    (license license:asl2.0)))
+
 (define-public python-rjsmin
   (package
     (name "python-rjsmin")