summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-10-05 14:28:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-05 14:28:24 +0200
commitbe1d561f1a74d158d67623bf037727918781bd96 (patch)
treec718d1bacc90d446becc1e2e52909315e4d1d336 /gnu
parent3f627bf56bfc6c1904cfea4c73d0a5afc72b25ee (diff)
downloadguix-be1d561f1a74d158d67623bf037727918781bd96.tar.gz
gnu: Add cd-hit-auxtools.
* gnu/packages/bioinformatics.scm (cd-hit-auxtools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index bb1aeac3a3..b467a8b828 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2476,6 +2476,26 @@ databases.")
     ;; version 2 (GPLv2)."
     (license license:gpl2)))
 
+(define-public cd-hit-auxtools
+  (package
+    (inherit cd-hit)
+    (name "cd-hit-auxtools")
+    (arguments
+     (list
+      #:tests? #f                       ; there are no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'chdir (lambda _ (chdir "cd-hit-auxtools")))
+          ;; No "configure" script
+          (delete 'configure)
+          ;; There is no install target.
+          (replace 'install
+            (lambda _
+              (for-each (lambda (file)
+                          (install-file file (string-append #$output "/bin")))
+                        '("cd-hit-dup" "cd-hit-lap" "read-linker")))))))
+    (inputs '())))
+
 (define-public clipper
   (package
     (name "clipper")