summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-12-14 13:06:48 -0500
committerLudovic Courtès <ludo@gnu.org>2020-12-21 17:47:36 +0100
commitc11fedf63c005059eda0d6c4cafee12908fc42e2 (patch)
tree479b6ba0fcb947855ecb1b5483f709bb1db5ba51 /gnu
parentc369a9078795ed04127bae6946be975530b1df10 (diff)
downloadguix-c11fedf63c005059eda0d6c4cafee12908fc42e2.tar.gz
gnu: sdcc: Expand comment regarding GPUTILS and PIC ports.
* gnu/packages/embedded.scm (sdcc)[arguments]: Expand comment to explain why
GPUTILS is not yet available and SDCC's PIC ports are disabled.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/embedded.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index da03d18c6d..a7643deb97 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1492,7 +1492,10 @@ and Zilog Z80 families, plus many of their variants.")
        ("python-2" ,python-2)
        ("texinfo" ,texinfo)))
     (arguments
-     `(;; gputils is required for PIC ports
+     `(;; GPUTILS is required for the PIC ports, but the licensing status of
+       ;; some of the files contained in its distribution is unclear (see
+       ;; https://issues.guix.gnu.org/44557).  For this reason it is not yet
+       ;; available as a package in Guix.
        #:configure-flags
        '("--disable-pic14-port" "--disable-pic16-port" "--disable-ucsim")
        #:phases