summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorFries <fries1234@protonmail.com>2023-08-05 11:01:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:42 +0100
commitc28b31964037beef27d79dab4a334400bd6937bd (patch)
treeddf1c021638ab283c64913c8a38c8da9362fd158 /gnu
parent12fd64c9f952189d82a8a6ba91f2178c479eb890 (diff)
downloadguix-c28b31964037beef27d79dab4a334400bd6937bd.tar.gz
gnu: Add go-github-com-chzyer-logex.
* gnu/packages/golang-xyz.scm (go-github-com-chzyer-logex): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I3c8038b999540f6cdff75f360a04f12b2753dd99
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d357584469..5f0dbf2bc4 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -17,6 +17,7 @@
 ;;; Copyright © 2021, 2023, 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
 ;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
+;;; Copyright © 2023 Fries <fries1234@protonmail.com>
 ;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
 ;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
@@ -607,6 +608,33 @@ similar to Go's standard library @code{json} and @code{xml} package.")
      "This package is a Go library that draws progress bars on the terminal.")
     (license license:bsd-3)))
 
+(define-public go-github-com-chzyer-logex
+  (package
+    (name "go-github-com-chzyer-logex")
+    (version "1.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/chzyer/logex")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0c9yr3r7dl3lcs22cvmh9iknihi9568wzmdywmc2irkjdrn8bpxw"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      ;; See <https://github.com/chzyer/logex/issues/4> and
+      ;; <https://github.com/chzyer/logex/pull/7>.
+      #:tests? #f
+      #:import-path "github.com/chzyer/logex"))
+    (home-page "https://github.com/chzyer/logex")
+    (synopsis "Golang log library")
+    (description
+     "This package provides a Golang log library supporting tracing and log
+levels that works by wrapping the standard @code{log} library.")
+    (license license:expat)))
+
 (define-public go-github-com-coocood-freecache
   (package
     (name "go-github-com-coocood-freecache")