summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:38:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commitc2d6e866ac8f480a98bcb27aa7c3cc5b8f588a23 (patch)
treefd7f61f4437267d0d4afe00ea99416589fb66628 /gnu
parent99c164a5c7a4c17a7d8770a4ec86906cb67b61d6 (diff)
downloadguix-c2d6e866ac8f480a98bcb27aa7c3cc5b8f588a23.tar.gz
gnu: Add r-drc.
* gnu/packages/cran.scm (r-drc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a3bc01ba0d..1b6196f4fd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10008,3 +10008,29 @@ parametric max-stable models, analysis of the extremal spatial dependence, the
 fitting of such processes using composite likelihoods or least square (simple
 max-stable processes only), model checking and selection and prediction.")
     (license license:gpl2+)))
+
+(define-public r-drc
+  (package
+    (name "r-drc")
+    (version "3.0-1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "drc" version))
+       (sha256
+        (base32
+         "0c8xn8ripzq270hy8d16fcnx02l02alddznd7fqwk3jyi6113h1y"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-car" ,r-car)
+       ("r-gtools" ,r-gtools)
+       ("r-mass" ,r-mass)
+       ("r-multcomp" ,r-multcomp)
+       ("r-plotrix" ,r-plotrix)
+       ("r-scales" ,r-scales)))
+    (home-page "https://cran.r-project.org/web/packages/drc")
+    (synopsis "Analysis of dose-response curves")
+    (description
+     "This package provides a suite of flexible and versatile model fitting
+and after-fitting functions for the analysis of dose-response data.")
+    (license license:gpl2+)))