summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:25 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-07-19 13:09:25 +0200
commitc31eea21ddb48bc66635b2681017e7e5e055fd59 (patch)
treeb47502e1c38cea09e4101949ab1b52fe0ac2c78b /gnu
parent5f6daad3c8ebd7d39e6f9fe94be264e8de6595c4 (diff)
downloadguix-c31eea21ddb48bc66635b2681017e7e5e055fd59.tar.gz
gnu: Add r-formula-tools.
* gnu/packages/cran.scm (r-formula-tools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index df0840502d..589bcd8f30 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29625,6 +29625,30 @@ to improve the readability of data presented in tabular form rendered in web
 pages.")
     (license license:expat)))
 
+(define-public r-formula-tools
+  (package
+    (name "r-formula-tools")
+    (version "1.7.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "formula.tools" version))
+              (sha256
+               (base32
+                "15d3ikfmsh9zszfgfkrxb3jkipl41inm7n6bhs73kwlnklnygq2g"))))
+    (properties `((upstream-name . "formula.tools")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-operator-tools))
+    (home-page "https://github.com/decisionpatterns/formula.tools")
+    (synopsis
+     "Utilities for manipulating formulas, calls, assignments and other R objects")
+    (description
+     "These utilities facilitate the programmatic manipulations of formulas,
+expressions, calls, assignments and other R language objects.  These objects
+all share the same structure: a left-hand side, operator and right-hand side.
+This packages provides methods for accessing and modifying this structures as
+well as extracting and replacing names and symbols from these objects.")
+    (license license:gpl2)))
+
 (define-public r-xmisc
   (package
     (name "r-xmisc")