summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:14:51 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:19 +0300
commitc498ff56d33ce4edec9a6f2a14c96860f9718237 (patch)
tree1f1531c713423fb7a5d268ae4151f328befbefa6 /gnu
parent1a73164da62f9cb51658493ec05692b26f6703c2 (diff)
downloadguix-c498ff56d33ce4edec9a6f2a14c96860f9718237.tar.gz
gnu: Add emacs-eros.
* gnu/packages/emacs.scm (emacs-eros): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3f7fcb8ae9..2482a37bf5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10148,3 +10148,26 @@ It provides syntax highlighting and automatic indentation and
 comes with sml-proc which allows interaction with an inferior SML
 interactive loop.")
     (license license:gpl3+)))
+
+(define-public emacs-eros
+  (let ((commit "a42e45c9b2397156c684330b0fc90ee0eba773f5")
+        (revision "1"))
+    (package
+      (name "emacs-eros")
+      (version (string-append "0.0.1" "-" revision "."
+                              (string-take commit 7)))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/xiongtx/eros.git")
+               (commit commit)))
+         (file-name (string-append name "-" version "-checkout"))
+         (sha256
+          (base32
+           "0whlsq90v13fz69k3wjrwcwb9gkpfxqjd75mg3nrp85j9nwhb5i4"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/xiongtx/eros")
+      (synopsis "Evaluation result overlays")
+      (description "@code{eros} provides evaluation result overlays.")
+      (license license:gpl3+))))