summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-07-18 22:53:50 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-18 22:53:50 +0200
commitc5c4c4b437f977f4aaedb34a258cd94146c93d4d (patch)
tree5067404a8cc00115f6f3aa22f8ac3fa6f3fc6000 /gnu
parent47f315a73f535550d404c22d09ab576991a2b3bf (diff)
downloadguix-c5c4c4b437f977f4aaedb34a258cd94146c93d4d.tar.gz
gnu: rapidjson: Build without -Werror.
* gnu/packages/web.scm (rapidjson)[source]: Add 'snippet'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 088aa0b2df..830d9db7dd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -272,7 +272,13 @@ parse JSON formatted strings back into the C representation of JSON objects.")
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
-               "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))))
+               "0rl6s0vg5y1dhh9vfl1lqay3sxf69sxjh0czxrjmasn7ng91wwf3"))
+             (modules '((guix build utils)))
+             (snippet
+              ;; Building with GCC 4.8 with -Werror was fine, but 4.9.3
+              ;; complains in new ways, so turn of -Werror.
+              '(substitute* (find-files "." "^CMakeLists\\.txt$")
+                 (("-Werror") "")))))
     (build-system cmake-build-system)
     (home-page "https://github.com/miloyip/rapidjson")
     (synopsis "JSON parser/generator for C++ with both SAX/DOM style API")