summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRikard Nordgren <hrn@posteo.net>2023-12-15 07:29:05 +0000
committerJelle Licht <jlicht@fsfe.org>2024-02-03 18:04:18 +0100
commitc70c513317de4fdeb0ca5a208cee3148b39f107c (patch)
treeb64c2b756045ea46fec126b960a40c855bea3ed6 /gnu
parentec27ba6161efbc37b740f2ba73f1f6cb1fd9c8c2 (diff)
downloadguix-c70c513317de4fdeb0ca5a208cee3148b39f107c.tar.gz
gnu: Add node-path-key.
* gnu/packages/node-xyz.scm (node-path-key): New variable

Change-Id: I0fc1cbbcf82622f4bf2dd6d2ca46b22605ea964a
Signed-off-by: Jelle Licht <jlicht@fsfe.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/node-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 9097d611a6..a47c525d14 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -702,6 +702,32 @@ Subsequent calls will either return the cached previous value or throw an error
 if desired.")
     (license license:isc)))
 
+(define-public node-path-key
+  (package
+    (name "node-path-key")
+    (version "4.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sindresorhus/path-key")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'patch-dependencies 'delete-dependencies
+                    (lambda _
+                      (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
+    (home-page "https://github.com/sindresorhus/path-key")
+    (synopsis "Cross-platform utility to compute the PATH environment variable key")
+    (description "@code{path-key} provides an implementation to compute the
+particular cross-platform spellings of the PATH environment variable key.")
+    (license license:expat)))
+
 (define-public node-ieee754
   (package
     (name "node-ieee754")