summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:50:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:35 +0200
commitc79c0f3fc120c99f99e5d2881e1873352847866b (patch)
treeeaa88d3296d7c15180bc9c5ab35a7f3df98fd4c9 /gnu
parent6341daac28d8b8b6a69d648b7f0175417831dc99 (diff)
downloadguix-c79c0f3fc120c99f99e5d2881e1873352847866b.tar.gz
gnu: Add texlive-pagella-otf.
* gnu/packages/tex.scm (texlive-pagella-otf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 091493fa2b..bc4cab7cc4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -20699,6 +20699,26 @@ package provides Metafont source for the font together with LaTeX support.")
 systems that use the Myanmar script.")
     (license license:silofl1.1)))
 
+(define-public texlive-pagella-otf
+  (package
+    (name "texlive-pagella-otf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/pagella-otf/"
+                   "tex/latex/pagella-otf/")
+             (base32
+              "0yi5d5wffqcrlslk9gxifnx4imhpi1hqya6x7k1qq9znvlf97inl")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pagella-otf")
+    (synopsis "Using the OpenType fonts TeX Gyre Pagella")
+    (description
+     "This package can only be used with LuaLaTeX or XeLaTeX.  It does the
+font setting for the OpenType font TeX Gyre Pagella for text and math.  The
+missing typefaces like bold math and slanted text are also defined.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-parallel
   (package
     (name "texlive-parallel")