summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-18 11:52:41 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:50 +0100
commitc7f93b1b8597d6d91b9956a40bc131c18412bbbe (patch)
tree0d5d3dba30196026a5bd07d866eda92d6ee1e48a /gnu
parentbe094d903801ea8008c2895dafd6ceb19393d3c6 (diff)
downloadguix-c7f93b1b8597d6d91b9956a40bc131c18412bbbe.tar.gz
gnu: ruby-shindo: Update to 0.3.10.
* gnu/packages/ruby.scm (ruby-shindo): Update to 0.3.10.
[arguments]: Update style.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c1d98e98d3..d1643e8a68 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3629,28 +3629,28 @@ It is a low-dependency variant of ruby-hydra.")
 (define-public ruby-shindo
   (package
     (name "ruby-shindo")
-    (version "0.3.8")
+    (version "0.3.10")
     (source (origin
               (method url-fetch)
               (uri (rubygems-uri "shindo" version))
               (sha256
                (base32
-                "0s8v1jbz8i0jh92f2fgxb3p51l1azrpkc8nv4mhrqy4vndpvd7wq"))))
+                "0qnqixhi0g8v44v13f3gynpbvvw6xqi1wajsxdjsx5rhzizfsj91"))))
     (build-system ruby-build-system)
     (arguments
-     `(#:test-target "shindo_tests"
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'fix-tests
-           (lambda _
-             (substitute* "tests/tests_helper.rb"
-               (("-rubygems") ""))
-             (substitute* "Rakefile"
-               (("system \"shindo") "system \"./bin/shindo")
-               ;; This test doesn't work, so we disable it.
-               (("fail \"The build_error test should fail") "#")
-               ((" -rubygems") ""))
-             #t)))))
+     (list
+      #:test-target "shindo_tests"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-tests
+            (lambda _
+              (substitute* "tests/tests_helper.rb"
+                (("-rubygems") ""))
+              (substitute* "Rakefile"
+                (("system \"shindo") "system \"./bin/shindo")
+                ;; This test doesn't work, so we disable it.
+                (("fail \"The build_error test should fail") "#")
+                ((" -rubygems") "")))))))
     (propagated-inputs
      (list ruby-formatador))
     (synopsis "Simple depth first Ruby testing")