summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-25 14:11:21 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:25 +0000
commitc8097564aed4c66efcedd3af1ed8ce5fc5f339fd (patch)
treecd045c3df4c3fb394b4c92bfbc577596f8d0f004 /gnu
parentde1c81287ab3eaad21c923e53b521c9250fef419 (diff)
downloadguix-c8097564aed4c66efcedd3af1ed8ce5fc5f339fd.tar.gz
gnu: gnome-weather: Update to 40.1.
* gnu/packages/gnome.scm (gnome-weather): Update to 40.1.
[source]: Fix the URI.
[inputs]: Add libhandy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3ff7d05aae..cc82878f90 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9245,15 +9245,15 @@ associations for GNOME.")
 (define-public gnome-weather
   (package
    (name "gnome-weather")
-   (version "3.34.0")
+   (version "40.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnome/sources/" name "/"
-                                (version-major+minor version) "/"
+                                (version-major version) "/"
                                 name "-" version ".tar.xz"))
             (sha256
              (base32
-              "1g63xzs17i36if923b36k9fwbk0nqa5vz6zh1k6q2axrzhhpx1i4"))))
+              "0k9wnyinvx6433r07kvjyahgqc605g7gbpf3d0h6vi4p8x61849x"))))
    (build-system meson-build-system)
    (native-inputs
     `(("gettext" ,gettext-minimal)
@@ -9268,7 +9268,8 @@ associations for GNOME.")
       ("gdk-pixbuf" ,gdk-pixbuf)
       ("gjs" ,gjs)
       ("gnome-desktop" ,gnome-desktop)
-      ("libgweather" ,libgweather)))
+      ("libgweather" ,libgweather)
+      ("libhandy" ,libhandy)))
    (arguments
     `(#:glib-or-gtk? #t
       #:phases