summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:32 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:34 +0200
commitc8b9440676ed51fa2685d3f3f5b51fa3b2ff3b75 (patch)
tree702b55680c2fb5375cb596ac68bad336f045a42f /gnu
parent85b537d9963753a23e50cc01c0214bfbbc2cf87f (diff)
downloadguix-c8b9440676ed51fa2685d3f3f5b51fa3b2ff3b75.tar.gz
gnu: Add texlive-recipecard.
* gnu/packages/tex.scm (texlive-recipecard): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2bdf576c82..9a33d64e38 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93708,6 +93708,29 @@ normal letterpaper easily.  The size was chosen to work in half-page 3-ring
 binder cover sheets.")
     (license license:lppl1.3+)))
 
+(define-public texlive-recipecard
+  (package
+    (name "texlive-recipecard")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/recipecard/"
+                   "source/latex/recipecard/"
+                   "tex/latex/recipecard/")
+             (base32
+              "0794jd9d28rjvwk6bx93al2dcavjrb341yjmivhmq74d504wahpf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (native-inputs (list (texlive-updmap.cfg (list texlive-hypdoc))))
+    (home-page "https://ctan.org/pkg/recipecard")
+    (synopsis "Typeset recipes in note-card-sized boxes")
+    (description
+     "The @code{recipecard} class typesets recipes into note card sized boxes that
+can then be cut out and pasted on to note cards.  The recipe then looks
+elegant and fits in the box of recipes.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar