summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-09-04 14:11:40 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-09-06 23:54:22 +0200
commitc98f9c52960735da672d5e9766bdfef5ff136a6e (patch)
tree617d70bb4a4b8881b478169293dac2763a8d2f4b /gnu
parent18e565bf67145b739703da9f13197f93e34c5284 (diff)
downloadguix-c98f9c52960735da672d5e9766bdfef5ff136a6e.tar.gz
gnu: python-tox: Update to 2.8.0.
* gnu/packages/python.scm (python-tox): Update to 2.8.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a190873515..c6f9f34ce7 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9886,14 +9886,14 @@ Pytest but stripped of Pytest specific details.")
 (define-public python-tox
   (package
    (name "python-tox")
-   (version "2.3.1")
+   (version "2.8.0")
    (source
     (origin
      (method url-fetch)
      (uri (pypi-uri "tox" version))
      (sha256
       (base32
-       "1vj73ar4rimq3fwy5r2z3jv4g9qbh8rmpmncsc00g0k310acqzxz"))))
+       "00lrql2cfzhb712v70inac6mrgdv8s8fmvz7qpggkk623hkm2pgc"))))
    (build-system python-build-system)
    (arguments
     ;; FIXME: Tests require pytest-timeout, which itself requires
@@ -9905,7 +9905,8 @@ Pytest but stripped of Pytest specific details.")
       ("python-virtualenv" ,python-virtualenv)))
    (native-inputs
     `(; FIXME: Missing: ("python-pytest-timeout" ,python-pytest-timeout)
-      ("python-pytest" ,python-pytest)))  ; >= 2.3.5
+      ("python-pytest" ,python-pytest)  ; >= 2.3.5
+      ("python-setuptools-scm" ,python-setuptools-scm)))
    (home-page "http://tox.testrun.org/")
    (synopsis "Virtualenv-based automation of test activities")
    (description "Tox is a generic virtualenv management and test command line